Scroll ImageMap may not load

Incident Report for K15t GmbH

Postmortem

Summary

On August 5, 2026, between 12:00 AM and 2:30 PM UTC, users of K15t’s Scroll Exporter apps and Scroll ImageMap experienced service disruption across all cloud regions. During this window, attempted exports failed for Scroll Exporter apps, and Scroll ImageMap content failed to render on Confluence pages. The incident was caused by an upstream change on Atlassian’s platform that blocked access to an API endpoint required for normal app operation. Upon detecting the issue, we immediately escalated it to Atlassian, who rolled back the change across Cloud instances. In parallel, our engineering team deployed a fallback fix to automatically reroute requests to an alternative API endpoint if the primary one becomes unavailable. Full service was restored for all affected apps once these changes were deployed.

Impact & Scope

The incident affected Confluence customers across all Cloud regions and tenants on August 5, 2026, between 12:00 AM and 2:30 PM UTC.

  • Scroll Exporter Apps (PDF, Word, HTML): Export functionality was completely unavailable during the incident window. Users attempting to export received an error notification in the Confluence UI upon failure.
  • Scroll ImageMap: Image-related content and corresponding hotspot navigation links failed to display within Scroll ImageMap macros on Confluence page views.

Root Cause & Resolution

The incident was caused by a configuration change on Atlassian's side affecting a Confluence Cloud REST API endpoint. The change resulted in requests to this endpoint being blocked, causing follow-up errors in Scroll PDF, Word, and HTML Exporters as well as Scroll ImageMap.

Upon detection, we escalated the issue to Atlassian as a Priority 1 ticket. Atlassian subsequently deployed a hotfix reverting the change and restoring access to the blocked endpoint. In parallel, we also deployed cloud updates enabling our apps to automatically failover to an alternative endpoint whenever the primary endpoint is unavailable.

Normal service for the Scroll Exporters was fully restored by 14:30 UTC on August 5, 2026.

Full rendering capability for Scroll ImageMap was also restored on August 5, 2026, with extended monitoring continuing until August 6, 2026 at 06:30 UTC, when the incident was officially marked as resolved.

Remedial Actions Plan & Next Steps

We know how critical these apps are to your team's day-to-day work, and we apologize for the disruption caused by this incident. To prevent similar issues and improve our response in the future, we are prioritizing the following actions:

  • Strengthen vendor communication: Establish tighter communication channels with Atlassian regarding planned API and platform changes to safeguard against unexpected breaking updates.
  • Enhance monitoring and alerting: Evaluate our monitoring tooling to identify coverage gaps and enable faster automated detection of upstream endpoint failures.
  • Implement in-app incident alerts: Improve user visibility during incidents by embedding status updates directly within our app interfaces, linked to the K15t status page.

Thank you for your patience and understanding while we resolved this issue, and please don't hesitate to reach out to our support team via help@k15t.com if you have any further questions.

Thanks,

The K15t Team

Posted Aug 12, 2026 - 14:58 CEST

Resolved

Every instance of Scroll ImageMap is back to normal again.
Posted Aug 06, 2026 - 08:30 CEST

Investigating

We are investigating this issue.
Posted Aug 05, 2026 - 17:26 CEST
This incident affected: Scroll Apps for Confluence (Scroll ImageMap).